e-Deklaracje pod Linux’em

strona.pngJak co roku należy rozliczyć się z fiskusem i jak co roku walczyć z e-deklaracjami przy pomocy archaicznych pakietów Adobe Air i Acrobat Reader.
Tym razem się udało, ale chyba co roku jest co raz trudniej. Czy mnie pamięć nie myli i w tym roku nie mieliśmy korzystać ze strony internetowej? Zostawmy to bez komentarza.

Instalacja e-Deklaracji dla jednych systemów jest łatwiejsza, a dla innych ciut trudniejsza.

Opis instalacji e-deklaracji z 2017 roku znajduje się tutaj: http://nocnypingwin.pl/e-deklaracje-pod-linuxem-2017/

1) W przypadku Arch‚a jest gotowa paczka w repozytorium AUR
https://aur.archlinux.org/packages/e-deklaracje/

2) Dla Ubuntu (15.10×64) już trzeba trochę się namęczyć:

Instalujemy trochę pakietów i linkujemy gnome-key-ring
sudo apt-get install libgtk2.0-0:i386 libstdc++6:i386 libnss3-1d:i386 lib32nss-mdns libxml2:i386 libxslt1.1:i386 libcanberra-gtk-module:i386 gtk2-engines-murrine:i386 libqt4-qt3support:i386 libgnome-keyring0:i386

sudo ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0
sudo ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0

Następnie ściągamy i instalujemy paczkę deb: ftp://ftp.adobe.com/pub/adobe/reader/unix/9.x/9.5.5/enu/AdbeRdr9.5.5-1_i386linux_enu.deb
sudo dpkg -i AdbeRdr9.5.5-1_i386linux_enu.deb
sudo apt-get install -f

Na koniec jeszcze instalacja paczki Adobe Air: http://airdownload.adobe.com/air/lin/download/latest/AdobeAIRInstaller.bin
chmod +x AdobeAIRInstaller.bin
sudo ./AdobeAIRInstaller.bin

I już możemy instalować edeklaracje, kliknięcie na link nie zadziałało mi więc ściągnąłem paczkę i dwa razy kliknąłem: http://www.finanse.mf.gov.pl/documents/766655/1196444/e-DeklaracjeDesktop.air

Jeżeli podczas instalacji instalator zapyta o hasło root’a, którego notabene u mnie nie rozpoznał to można uruchomić np. nautilusa z sudo: sudo nautilus, kliknąć paczkę, zakończyć instalację, zamknąć program oraz nautilusa i otworzyć e-deklarację jako zwykły użytkownik.

3) Dla openSUSE Leapx64 nieco prościej aczkolwiek acrobat reader z repozytoriów nie dogadywał się z e-deklaracjami.

Ściągamy rpm’a ze strony Adobe Reader’a i instalujemy: ftp://ftp.adobe.com/pub/adobe/reader/unix/9.x/9.5.5/enu/AdbeRdr9.5.5-1_i486linux_enu.rpm
sudo zypper install  AdbeRdr9.5.5-1_i486linux_enu.rpm
sudo zypper install libxslt1-32bit libgnome-keyring0-32bit rpm-build

Ściągamy i instalujemy Adobe AIR:
airdownload.adobe.com/air/lin/download/2.6/adobeair.i386.rpm
sudo zypper install adobeair.i386.rpm (przy pytaniu o klucze wybieramy opcję i)

Teraz wystarczy już przejść na stronę e-deklaracji i kliknąć na animowany banner co powinno uruchomić instalatora. Jeśli nie widać bannera to oznacza, że nie mamy zainstalowanego flasha.

http://www.finanse.mf.gov.pl/web/wp/pp/e-deklaracje/do-pobrania/-/asset_publisher/rG2P/content/aplikacja-e-deklaracje-desktop-umozliwiajaca-osobom-fizycznym-zlozenie-formularzy-elektronicznych-bez-podpisu-kwalifikowanego?redirect=http%3A%2F%2F10.0.61.164%2Fweb%2Fwp%2Fpp%2Fe-deklaracje%2Fdo-pobrania%3Fp_p_id%3D101_INSTANCE_rG2P%26p_p_lifecycle%3D0%26p_p_state%3Dnormal%26p_p_mode%3Dview%26p_p_col_id%3Dcolumn-2%26p_p_col_count%3D1#p_p_id_101_INSTANCE_rG2P_

Zrzut ekranu z 2016-02-15 00-41-15

3 komentarze

    • muki, 16 lutego 2016, 09:59

    Odpowiedz

    Dzięki – instrukcja dla OpenSUSE działa znakomicie!

    • MF_hate, 25 kwietnia 2016, 21:28

    Odpowiedz

    A ja mam już na końcu przy instalacji eDeklaracji:
    „Nie można zainstalować aplikacji. Spróbuj zainstalować ją ponownie. Jeśli problem będzie się powtarzał, skontaktuj się z autorem aplikacji.
    Numer błędu: 1”

    Ktoś wie o co chodzi? KUbuntu 15.10..

    • quina, 25 kwietnia 2016, 21:43

    Odpowiedz

    Wielkie dzięki!
    U mnie na 14.04 działa:-) Jedynie dwuklik na *.air nie zadziałał i musiałem z poziomu aplikacji znaleźć.

Dodaj komentarz

Twój adres e-mail nie zostanie opublikowany.