Instalacja Ubuntu 12.10 – uwaga użytkownicy kart Nvidia/AMD

Premierę nowego Ubuntu 12.10 Quantal Quetzal mamy już za sobą wraz ze wszystkimi remixami. Sam proces instalacyjny przebiega bez problemow, mam nawet złudzenie, że ciut szybciej .

Po pierwszym restarcie pojawia się ekran logowania, później środowisko Unity, żadnych problemów, ale… w odróżnieniu od poprzedniej wersji Ubuntu 12.04 (chociaż mógł to być bug) domyślnie uruchomiony jest otwarty sterownik Nvidii/AMD.

Chcąc włączyć sterownik własnościowy należy przejść do: Aktualizacji oprogramowania -> Ustawienia… -> Dodatkowe sterowniki i zaznaczyć pasujący sterownik… STOP

Niestety pojawił się bug i podczas instalacji Ubuntu odinstalowane zostały pakiety linux-source i linux-headers potrzebne do instalacji sterownika własnościowego tak więc przed instalacją należy zainstalować te pakiety:

sudo apt-get install linux-source
uname -a (sprawdzamy wersję posiadanego kernela np.)
sudo apt-get install linux-headers-3.5.0-17-generic

Jeżeli ktoś już zdążył zainstalować sterownik, a po logowaniu pojawia się pusty pulpit to też nie ma problemu 😉

ctrl-alt-t
sudo apt-get install linux-source
sudo apt-get install linux-headers-3.5.0-17-generic
sudo apt-get remove nvidia-current (lub nvidia-current-updates lub nvidia-experimental-304 lub pakiet amd)

sudo apt-get install nvidia-current-updates

Jeśli wszystko przebiegło bez problemów wystarczy zrestartować komputer.

sudo reboot

    • ruddaboy, 24 października 2012, 09:23

    Odpowiedz

    Bardzo dziękuję za rozwiązanie nurtującego mnie problemu. 😀

    • muki, 29 października 2012, 10:31

    Odpowiedz

    Uff, ten post oszczędził mi koszmaru po-instalacyjnego :] Swoją drogą, jak można wypuszczać tak pełny bugów soft? Niestety drużyna Ubuntu coraz bardziej obniża jakość swoich testów :/

    • Anonimowy, 26 listopada 2012, 15:24

    Odpowiedz

    W przypadku GT218 [GeForce 210] – NIE DZIAŁA!

  1. Odpowiedz

    Ale co nie dziala?

    • Anonimowy, 10 grudnia 2012, 20:26

    Odpowiedz

    A ja się zdziwiłem koszmarną jakością grafiki i często całkowitą zwiechą Xów po przejściu z 12.04 na 12.10. Na szczęście sterownik własnościowy rozwiązał te problemy. Trochę za późno trafiłem na tą stronę, niemniej jednak szacun dla autora, na pewno pomogło wielu ludziom.
    A tak BTW to muki ma rację. Ciekawe czy ktoś to w ogóle testował?
    Pozdruffka!

    • Anonimowy, 7 marca 2013, 10:15

    Odpowiedz

    u mnie tez nie działa po wykonianiu wszystkich czynnosci dalej pusty ekran ale i tk szacunek za ta wiadomosc moze ktos mi pomoze to jakos wgrac asus k73s nvidia gt 540m pozdrawiam

  2. Odpowiedz

    U ciebie problem jest inny i wynika z technologii optimus, ktora masz w laptopie czyli dwie karty graficzne: intel i nividia. Na szczescie jest projekt/program pod linuxem. ktory oblusguje to ustrojstwo: http://bumblebee-project.org/

  3. Odpowiedz

    Mialem podobne problemy juz we wczesniejszych wersjach. Nie rozumiem dlaczego najpierw nie naprawia wiekszosci bugow zanim wypuszcza nowe wersje. Moim zdanie 12.10 bylo zbedne lepiej bylo rozwijac 11 by pozbyc sie czestych bugow.

    • elcia3, 23 marca 2013, 20:02

    Odpowiedz

    wyświetlaja mi się informacje, że nie odnaleziono pakiretu. Co teraz?

  4. Odpowiedz

    Szukałem kilka godzin i wreszcie znalazłem. Dzięki za pomoc.

Dodaj komentarz

Twój adres e-mail nie zostanie opublikowany.