Problemy z Adobe Reader 9 (w tym z e-deklaracjami)

Adobe Reader 9.5 to ostatnia wersja natywnie „działająca” pod linuxem. Od prawie 10 lat Adobe nie wydało żadnej aktualizacji ani nie zamierza wydać. Niestety adobe reader jest wciąż wymagany przez e-deklaracje do działania. Uruchomienie samych e-deklaracji jest coraz to trudniejsze do instalacji co opisywałem tutaj: http://nocnypingwin.pl/e-deklaracje-pod-linuxem-2017/

W tak zwanym międzyczasie coraz więcej użytkowników (głównie adobe readera) zaczęło donosić o samoistnie zamykających się dokumentach, tak mniej więcej 15s sekund od otwarcia. Podobnie jest z e-deklaracjami. Rozwiązania permanentnego raczej nie ma się co spodziewać, ale pojawiły się pewne obejścia problemu, która mogą (ale nie muszą pomóc).

Oto one:

 

– użyć innego czytnika pdf’ów lub reader’a pod Wine (ten wariant nie zadziała z e-deklaracjami)
– zakomentować w pliku /etc/hosts linię ::1 odpowiadającą za ipv6 (ten wariant wydaje się działać z e-deklaracjami)
– usunąć (lepiej zmienić nazwę) plik /opt/Adobe/Reader9/Reader/intellinux/plug_ins/EFS.api (nie testowałem tego rozwiązania z e-deklaracjami)

3 komentarze

    • mexican_breakfast, 23 marca 2017, 19:47

    Odpowiedz

    kocham Cie człowieku…
    rady są złote. działa.

  1. Odpowiedz

    Spytam. Czy u Ciebie Nocny Pingwinie e-deklaracje wołają ze serwer nie zaufany?

    1. Nocny Pingwin

      Odpowiedz

      Owszem, można to zignorować. Następnym razem trzeba przyjrzeć się certyfikatom, z których korzystają e-deklaracje.

Dodaj komentarz

Twój adres e-mail nie zostanie opublikowany.